$re = '/^[0-9]+[a-zA-Z]$/';
$str = '71A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);