$re = '/^[a-zA-Z]\w{5,11}$/';
$str = 'jiang5_';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);