#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*($|#|\w+\s*=|(\?|\*|(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[0-5]?(?:\d|\*))(?:(?:-|\/|\,)(?:[0-5]?\d))?(?:,(?:[0-5]?\d)(?:(?:-|\/|\,)(?:[0-5]?\d))?)*)\s+(\?|\*|(?:[01]?(?:\d|\*)|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?(?:,(?:[01]?\d|2[0-3])(?:(?:-|\/|\,)(?:[01]?\d|2[0-3]))?)*)\s+(\?|\*|(?:0?[1-9]|[12]\d|3[01]|\*)(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?(?:,(?:0?[1-9]|[12]\d|3[01])(?:(?:-|\/|\,)(?:0?[1-9]|[12]\d|3[01]))?)*|(?:L)|(?:LW)|(?:L-(?:[0-9]|1\d|2\d|30))|(?:\dW|1\dW))\s+(\?|\*|(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?(?:,(?:[1-9]|1[012])(?:(?:-|\/|\,)(?:[1-9]|1[012]))?(?:L|W)?)*|\?|\*|(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?(?:,(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)(?:(?:-)(?:JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC))?)*)\s+(\?|\*|(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?(?:,(?:[1-7])(?:(?:-|\/|\,|#)(?:[1-7]))?(?:L)?)*|\?|\*|(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?(?:,(?:MON|TUE|WED|THU|FRI|SAT|SUN)(?:(?:-)(?:MON|TUE|WED|THU|FRI|SAT|SUN))?)*)(|\s)+(\?|\*|(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?(?:,(?:|\d{4})(?:(?:-|\/|\,)(?:|\d{4}))?)*))$"
Local $sString = "* * * ? * *" & @CRLF & _
"0 0/1 * * * ?" & @CRLF & _
"0/5 14,18,3-39,52 * ? JAN,MAR,SEP MON-FRI 2002-2010" & @CRLF & _
"0 * * ? * *" & @CRLF & _
"0 */2 * ? * *" & @CRLF & _
"0 1/2 * ? * *" & @CRLF & _
"0 */3 * ? * *" & @CRLF & _
"0 */4 * ? * *" & @CRLF & _
"0 */5 * ? * *" & @CRLF & _
"0 */10 * ? * *" & @CRLF & _
"0 */15 * ? * *" & @CRLF & _
"0 */30 * ? * *" & @CRLF & _
"0 15,30,45 * ? * *" & @CRLF & _
"0 0 * ? * *" & @CRLF & _
"0 0 */2 ? * *" & @CRLF & _
"0 0 0/2 ? * *" & @CRLF & _
"0 0 1/2 ? * *" & @CRLF & _
"0 0 */3 ? * *" & @CRLF & _
"0 0 */4 ? * *" & @CRLF & _
"0 0 */6 ? * *" & @CRLF & _
"0 0 */8 ? * *" & @CRLF & _
"0 0 */12 ? * *" & @CRLF & _
"0 0 0 * * ?" & @CRLF & _
"0 0 1 * * ?" & @CRLF & _
"0 0 6 * * ?" & @CRLF & _
"0 0 12 * * ?" & @CRLF & _
"0 0 12 ? * SUN" & @CRLF & _
"0 0 12 ? * MON" & @CRLF & _
"0 0 12 ? * TUE" & @CRLF & _
"0 0 12 ? * WED" & @CRLF & _
"0 0 12 ? * THU" & @CRLF & _
"0 0 12 ? * FRI" & @CRLF & _
"0 0 12 ? * SAT" & @CRLF & _
"0 0 12 ? * MON-FRI" & @CRLF & _
"0 0 12 ? * SUN,SAT" & @CRLF & _
"0 0 12 */7 * ?" & @CRLF & _
"0 0 12 1 * ?" & @CRLF & _
"0 0 12 2 * ?" & @CRLF & _
"0 0 12 15 * ?" & @CRLF & _
"0 0 12 1/2 * ?" & @CRLF & _
"0 0 12 1/4 * ?" & @CRLF & _
"0 0 12 L * ?" & @CRLF & _
"0 0 12 L-2 * ?" & @CRLF & _
"0 0 12 L-12 * ?" & @CRLF & _
"0 0 12 L-22 * ?" & @CRLF & _
"0 0 12 L-30 * ?" & @CRLF & _
"0 0 12 LW * ?" & @CRLF & _
"0 0 12 1W * ?" & @CRLF & _
"0 0 12 15W * ?" & @CRLF & _
"0 0 12 ? * 2#1" & @CRLF & _
"0 0 12 ? * 6#1" & @CRLF & _
"0 0 12 ? * 2#2" & @CRLF & _
"0 0 12 ? * 5#3" & @CRLF & _
"0 0 12 ? JAN *" & @CRLF & _
"0 0 12 ? JUN *" & @CRLF & _
"0 0 12 ? JAN,JUN *" & @CRLF & _
"0 0 12 ? DEC *" & @CRLF & _
"0 0 12 ? JAN,FEB,MAR,APR *" & @CRLF & _
"0 0 12 ? 9-12 *" & @CRLF & _
"0 1 0 ? * 7" & @CRLF & _
"0 59 23 ? * 7,2,1,5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")