# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?>\<\!--begin(?<type>\w+)--\>)(?<embed>.+)(?>\<\!--end(?>\1)--\>)"
test_str = ("<p><!--beginTweet--></p><blockquote class=\"twitter-tweet\"><p dir=\"ltr\" lang=\"en\">The <a href=\"https://twitter.com/hashtag/SeaKraken?src=hash&ref_src=twsrc%5Etfw\">#SeaKraken</a> & <a href=\"https://twitter.com/ClimateArena?ref_src=twsrc%5Etfw\">@ClimateArena</a> will require all guests, ages 12+, attending Kraken games, concerts & events at Climate Pledge Arena to provide proof of vaccination to keep fans, staff, players & artists safe.<br><br>More info → <a href=\"https://t.co/f2EmV5cXd0\">https://t.co/f2EmV5cXd0</a> <a href=\"https://t.co/wJY9ElJ0DQ\">pic.twitter.com/wJY9ElJ0DQ</a></p>— Seattle Kraken (@SeattleKraken) <a href=\"https://twitter.com/SeattleKraken/status/1435273531256885255?ref_src=twsrc%5Etfw\">September 7, 2021</a></blockquote><p><!--endTweet--></p>\n"
"<!--beginFart-->df<!--endFart-->")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.