$re = '/^[1-9]{1}\d{2}\s?\d{3}$/m';
$str = '110085
jka
1212
12389189';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);