use strict;
my $str = '
kim_reel05_scn0101_shot0770
n74_reel05_scn0001_shot0700
ninehundred_reel05_scn0001_shot0700';
my $regex = qr/[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}