# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:BSSID +: (?<bssid>[a-z0-9]{2}(?::[a-z0-9]{2}){5}))|(?:Signal +: (?<signal>\d+)%)"
test_str = ("There is 1 interface on the system:\n\n"
" Name : Wi-Fi\n"
" Description : Intel(R) Wi-Fi 6 AX201 160MHz\n"
" GUID : random_guid\n"
" Physical address : 36:fe:a6:54:12:b0\n"
" Interface type : Primary\n"
" State : connected\n"
" SSID : random_ssid\n"
" BSSID : 36:fe:a6:54:12:b0\n"
" Network type : Infrastructure\n"
" Radio type : 802.11ac\n"
" Authentication : WPA2-Personal\n"
" Cipher : CCMP\n"
" Connection mode : Auto Connect\n"
" Band : 5 GHz\n"
" Channel : 149\n"
" Receive rate (Mbps) : 866.7\n"
" Transmit rate (Mbps) : 780\n"
" Signal : 85%\n"
" Profile : random_profile")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.