#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<assign_op>(\:|\!|\?)?=)|(?P<token_subst>$|%(\<\@))|(?P<token_ident>[\w\d\.\,]+)|(?P<target_name_match>%\.?)|(?P<token_rule_sep>[:])|(?P<incr_op>\n)|(?P<line_end>\n)|(?P<comment_op>#[.*]+$)|(?P<adjust_parser>[\$%\s\t\:])"
Local $sString = "CC := nasm" & @CRLF & _
"BOOT_REQ := text.o" & @CRLF & _
"FREELDR_SRCS := freeldr.c" & @CRLF & _
"IMG_NAME := boot.img" & @CRLF & _
"" & @CRLF & _
"TEXT_SECTION := 7c00" & @CRLF & _
"" & @CRLF & _
"# UFS2, ZFS and/or RAW" & @CRLF & _
"FILESYSTEMS :=" & @CRLF & _
"CPU_FLAGS := PAE" & @CRLF & _
"SDK_FLAGS :=" & @CRLF & _
"VERSION := "1.00.00"" & @CRLF & _
"" & @CRLF & _
"%.o:" & @CRLF & _
" $(ASM) ${SDK_FLAGS} -f bin -o $@ $(patsubst %.bin,%.asm,$@))" & @CRLF & _
"" & @CRLF & _
"${IMG_NAME}:" & @CRLF & _
" $(BOOT_REQ) $(FREELDR_SRCS:.c=.o)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")