using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script[^>]+>[\s|\S]*('facebook-jssdk'\)\);
\/\/ ]]><\/script>)";
string input = @"<p><em>ขอขอบคุณข้อมูลจาก <a href=""https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3"">เฟซบุ๊ก Crewabs Cabincrew</a></em></p>
<script type=""text/javascript""></script>asdasd
asdasdasd
asdad
<script type=""text/javascript"">// <![CDATA[
(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = ""//connect.facebook.net/th_TH/sdk.js#xfbml=1&version=v2.3""; fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));
// ]]></script>
<div class=""fb-post"" data-href=""https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3"" data-width=""500"">
<div class=""fb-xfbml-parse-ignore"">
<blockquote cite=""https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3"">
<p>จากใจแอร์สาวบนไฟล์ทที่โดนหนุ่มรถไฟจีบด้วยมุก""ระเบิด""กรณีหนุ่มรถไฟ แซวแอร์ไทยไลอ้อน อยากขอพื้นที่ชี้แจงให้ลูกเรือสาวในไ...</p>
Posted by <a href=""https://www.facebook.com/CrewabsCabincrew/"">Crewabs Cabincrew</a> on <a href=""https://www.facebook.com/CrewabsCabincrew/photos/a.163266007065328.35057.162290157162913/981295968595657/?type=3"">3 พฤศจิกายน 2015</a></blockquote>
</div>
</div>
</div>
</div>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}