#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<day>0[1-9]|1\d|2[1-8]|29(?=-\d{2}-(?!1[26]00|2[048]00)\d{2}(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(?<month>0[1-9]|1[0-2])-(?<year>[12]\d{3}) (?<hour>[01]\d|2[0-3]):(?<minute>[0-5]\d):(?<second>[0-5]\d)$"
Local $sString = "29-02-1600 15:11:45" & @CRLF & _
"29-02-1604 23:59:59" & @CRLF & _
"29-02-2001 15:11:45" & @CRLF & _
"31-01-2000 00:00:00" & @CRLF & _
"30-02-2000 15:11:45" & @CRLF & _
"29-02-2004 15:11:45" & @CRLF & _
"31-02-2000 15:11:45" & @CRLF & _
"31-12-2000 15:11:45" & @CRLF & _
"31-06-2000 15:11:45" & @CRLF & _
"15-02-2000 15:11:45" & @CRLF & _
"29-02-2002 15:11:45" & @CRLF & _
"02-02-2000 15:11:45" & @CRLF & _
"29-02-2000 15:11:45" & @CRLF & _
"28-02-2000 15:11:45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")