import Foundation
let pattern = #"(([0-9]+((.|,)[0-9])*)\s\btablespoons?\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"9 Super 7 Carburetors RPM Torque (lb-ft) Horsepower 3,300 375.0 235.6 3,400 367.4 237.8 3,500 368.0 245.2 3,600 366.1 250.9 3,7000 360.3 295.0 4,400 362.9 304.0 4,500 367.0 314.5 4,600 364.0 318.8 4,700 363.1 324.9 4,800 361.0 329.9 4,900 352.5 328.9 5,000 350.0 333.2 5,100 353.1 mhfgdjytgtrd 5 tablespoons"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)