re = /^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9])$/
str = 'this is a ✖ to find 123
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end