$re = '/(\.(?=\d)|:|\/)/m';
$str = '.w-2.5.sm:w-1/2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);