import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w-\\+\\.\\_]+(\\.[\\w-\\+\\.\\_]+)*@[\\w-\\+\\.\\_]+(\\.[\\w\\+\\.\\_]+)*(\\.[A-Za-z]{2,})$";
final String string = "^[\\\\w-\\\\+\\\\.\\\\_]+(\\\\.[\\\\w-\\\\+\\\\.\\\\_]+)*@[\\\\w-\\\\+\\\\.\\\\_]+(\\\\.[\\\\w\\\\+\\\\.\\\\_]+)*(\\\\.[A-Za-z]{2,})$\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}