$re = '/([\d]+[.][\d]+)|([\d]+)|([\+\-\*\/\^]+)|([\(\)])*/';
$str = '123.123-0.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);