import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"""
(?: \A | (?<= [\s\xA0\(\[\{]))
(?P<MODEL>
(?:
(?:
[A-ZА-Я]{4,6} (?! [\s\xA0] )
|
(?! (?: D-Link | D-LINK | Asus | ASUS | USB ) [\s\xA0] )
[A-ZА-Я]{1,4} (?: \d [A-ZА-Я\d]{0,4} )?
|
\d{2,5} (?= [\-/] )
)
(?:
(?! \s\d{1,2} - (?: Port | PORT ) )
[\s\xA0\-/\.]
(?:
\d{1,4} [A-ZА-Я\d]{0,4}
|
[A-ZА-Я]{1,4} [\-/]? \d{1,4} \w{0,8}
|
[A-ZА-Я] \w{3,6}
)
(?: [\-/] [A-ZА-Я\d]{1,3} )?
){1,4}
|
\d{1,4}
(?! [\s\xA0] USB [\s\xA0] )
[\s\xA0]?
(?! [kкKК]? (?: [WВAА] | В[Тт] | W[Tt] | Ватт | Watts? | Амп | Amp | Ампер | Ampers? ) \b )
[A-ZА-Я] [A-ZА-Я\d]{0,5}
|
[A-ZА-Я]{1,4} \d [A-ZА-Я\d]{0,10}
)
(?:
[\-/] \w{1,6} (?: [\-/] \d{1,3} )?
|
(?: [\s\x0A] [A-ZА-Я\d]{1,5} (?: [\-/] [A-ZА-Я\d]{1,5} ){0,2} ){1,3}
)?
(?: \+ | [\s\xA0] (?: Plus | PLUS | Плюс | ПЛЮС) )?
(?: [\s\xA0]? \( [A-ZА-Я\d\-/]{1,18} \) )?
)
(?= \Z | [\s\xA0,\.\)\}\]] | (?<= \) ) [:;\-/] )
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"Автомагнитола ALPINE CDE-100EUB Код товара: 1298, Производитель: ALPINE, раздел: Автомагнитолы, модель: ALPINE CDE-100EUB"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}