$re = '/spot2(.*)/';
$str = 'www.cargo-partner.com/spot2/cp/*';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);