$re = '/(?<=\/\/:)[\r\n]*(.*?)(?=[\r\n]*\/\/\~[\r\n]*\*)/s';
$str = '*Listing 1.
//:
some code
//~
*
*Listing 2.
//:
some new code
//~
*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);