$re = '/^.*([A-Za-z]).*\1.*$/';
$str = 'Ksnnsn';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);