$re = '/(?:\+|\-)(?=([^"]*"[^"]*")*[^"]*$)/m';
$str = '"数据A+数据B"+数据C-数据D+"数据C-数据E"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);