$re = '/\(((\d+)\s?){2,3}\)\s?((\d+)\s?){2,5}/m';
$str = '(05 121) 299 38 38';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);