# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<year>\d{4})[-\/](?<month>0[1-9]|1[0-2])[-\/](?<day>0[1-9]|[1-2][0-9]|3[0-1])(?:[T\s](?:(?<hour>0[0-9]|1[0-9]|2[0-4]):(?<minute>\d{2}):(?<second>\d{2})(?:\.(?<nano>\d+))?))?(?:(?<offset>[Zz]|(?:[+-])(?:[01]\d|2[0-3])(?::?[0-5]\d)?)?)$"
test_str = ("2020-12-01T12:13:51.123+02:00\n"
"2020-12-01T12:13:51.123+0200\n"
"2020-12-01T12:13:51.123Z\n"
"2020-12-01T12:13:51.123\n"
"2020-12-01T12:13:51.123341512+02:00\n"
"2020-12-01T12:13:51.123341512+0200\n"
"2020-12-01T12:13:51.123341512Z\n"
"2020-12-01T12:13:51.123341512\n"
"2020-12-01T12:13:51+02:00\n"
"2020-12-01T12:13:51+0200\n"
"2020-12-01T12:13:51Z\n"
"2020-12-01T12:13:51\n"
"2020-12-01 12:13:51.123 +02:00\n"
"2020-12-01 12:13:51.123 +0200\n"
"2020-12-01 12:13:51.123Z\n"
"2020-12-01 12:13:51.123\n"
"2020-12-01 12:13:51.123341512 +02:00\n"
"2020-12-01 12:13:51.123341512 +0200\n"
"2020-12-01 12:13:51.123341512Z\n"
"2020-12-01 12:13:51.123341512\n"
"2020-12-01 12:13:51+02:00\n"
"2020-12-01 12:13:51+0200\n"
"2020-12-01 12:13:51Z\n"
"2020-12-01 12:13:51\n"
"2020-12-01+02:00\n"
"2020-12-01+0200\n"
"2020-12-01Z\n"
"2020-12-01\n"
"2020/12/01T12:13:51.123+02:00\n"
"2020/12/01T12:13:51.123+0200\n"
"2020/12/01T12:13:51.123Z\n"
"2020/12/01T12:13:51.123\n"
"2020/12/01T12:13:51.123341512+02:00\n"
"2020/12/01T12:13:51.123341512+0200\n"
"2020/12/01T12:13:51.123341512Z\n"
"2020/12/01T12:13:51.123341512\n"
"2020/12/01T12:13:51+02:00\n"
"2020/12/01T12:13:51+0200\n"
"2020/12/01T12:13:51Z\n"
"2020/12/01T12:13:51\n"
"2020/12/01+02:00\n"
"2020/12/01+0200\n"
"2020/12/01Z\n"
"2020/12/01\n"
"2039/15/23\n"
"2923/09/12\n"
"2023/23/51\n"
"2020-12-01T00:13:51\n"
"2020-12-01T01:13:51\n"
"2020-12-01T10:13:51\n"
"2020-12-01T19:13:51\n"
"2020-12-01T20:13:51\n"
"2020-12-01T24:13:51")
subst = "$1-$2-$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.