package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)among ?(o|u)s`)
var str = `amongos
amongus
among us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}