$re = '/(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])/i';
$str = 'P . .. 0 BIN';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);