package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.\d+)?\b`)
var str = `1
1.1222223232
.3
2.5
2.3
2.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}