use strict;
my $str = 'select * from a where #myTable$@_¥£.$@_¥£#columnName like (\'%\'+@p2+\'%\')
select * from a where #myTable$_¥£.$_¥£#columnName like (\'%\'+@p2+\'%\')
(\\w|\\[|\\]|\\.|\\s|\'|\\+|\\(|\\)|\\,)
select a from b where h like (\'%\'+@p2+\'%\')
having b.d like (\'%\'+@p2)
)join c on a.b like (@p2+\'%\')
and a.b like (@p2)
if a like (\'%abc24\'\'as\'+@p2+\'%\')
case when a like (\'%\'+@p2+\'%\')
where (((a like (\'%\'+ @p2+\'%\'))))
where a + \'b\' like (\'%\'+@p2+\'%\')
where concat(a,b) like (\'%\'+@p2+\'%\') or ltrim(a) like (\'%\'+@p2+\'%\')
select * from a where concat(a,b) like \'a\' and c like d or ltrim(a) like (\'%\'+@p2+\'%\')
where isnull(ltrim(a), \'0\') like (\'%\'+@p2+\'%\')
where a + \'b\' LIKe (\'%\'+@p2+\'%\')
vICM_EVENTlike roadshowev0like_ where upper(roadshowev0like_.EVENT_NAME) like (\'%\'+@p1+\'%\') or upper(roadshowev0like_.EVENT_SYMBOLlike) like (\'%\'+@p2+\'%\') and e_.EVENT_SYMBOLike like(\'%\'+@p2+\'%\')
from vICM_INVESTOR investor0_ where (upper(investor0_.OrgId) like (\'%\'+@p1+\'%\') or upper(investor0_.Name) like (\'%\'+@p2+\'%\')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc
where ((h.g) + upper(concat(investor0_.OrgId, \'d\') + (a.d)) like (\'%\'+@p1+\'%\')
or upper(investor0_.Name) like (\'%\'+@p2+\'%\')) and investor0_.IsDeactivated=@p3 order by investor0_.Name asc
where (a.b like (\'%\'+@p2+\'%\')) and d.g like (\'%\'+@p2+\'%\')
(where a.b like (\'%\'+@p2)
if a like (\'%\'+@p2)
join a on b.d like (\'%\'+@p2)
// not supported
where a like \'b\' and c like (\'%\'+@p2+\'%\')
where a like (\' \'+@p1+\'%\')
// supported
where a like (\'%\'+@p1+\'%\') and c like (\'%\'+@p2+\'%\')
';
my $regex = qr/((?<=[ )()']where)|(?<=[ )()']and)|(?<=[ )()']o[rn])|(?<=[ )()']if)|(?<=[ )()']when)|(?<=having))+(\s|\()+[)(,'+_¥£$#\@\w\[\]\.\s]+like\s*\(?\s*(('((\w|%|'{2})*)')\s*\+)*\s*@p\d+\s*(\+('%'))*\)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}