import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+]?([0-9]*[\\.\\s\\-\\(\\)]|[0-9]+){3,24}$";
final String string = "011 (416) 457 7845\n"
+ "+1 (416) 457 7845\n"
+ "011416457111\n"
+ "Standard Telephone numbers\n"
+ "+61 1 2345 6789\n"
+ "+61 01 2345 6789 (zero entered is not required but enterd by user anyway)\n"
+ "01 2345 6789\n"
+ "01-2345-6789\n"
+ "(01) 2345 6789\n"
+ "(01) 2345-6789\n"
+ "1234 5678\n"
+ "1234-5678\n"
+ "12345678\n\n"
+ "^(\\+[1-9][0-9]*(\\([0-9]*\\)|-[0-9]*-))?[0]?[1-9][0-9\\- ]*$\n\n"
+ "^(\\+[1-9][0-9]*(\\([0-9]*\\)|-[0-9]*-))?[0]?[1-9][0-9\\- ]*$\n\n"
+ "^\\+([0-9]( |-|\\+)?)?(\\(?[0-9]{3}\\)?|[0-9]{3})( |-)?([0-9]{3}( |-)?[0-9]{4}|[a-zA-Z0-9]{7})$\n\n"
+ "^((\\\\+[1-9]{1,4}[ \\\\-]*)|(\\\\([0-9]{2,3}\\\\)[ \\\\-]*)|([0-9]{2,4})[ \\\\-]*)*?[0-9]{3,4}?[ \\\\-]*[0-9]{3,4}?$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}