re = /https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*/i
str = 'https://www.asd.google.com/search?q=some+text¶m=3#dfsdf
https://www.google.com
http://google.com/?q=some+text¶m=3#dfsdf
https://www.google.com/api/?
https://www.google.com/api/login.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end