$re = '/^010[0169]{1}\d{7}$/';
$str = '01005555555';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);