$re = '~^(|\/.*)$~';
$str = '/passportuyg
/derp
/esi_and then
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);