$re = '/^[0-9]{2}[\s]?[0-9]{4}[-]?[0-9]{4}$/';
$str = '1146393083';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);