#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:https?:\/\/)?(?:www\.)?[\d\w\.-]+(?:\.|:)(?:[a-z\.]{2,6}|\d+)\/?.*$"
Local $sString = "https://regex101.com/" & @CRLF & _
"https://www.variables.sh/complex-regular-expression-examples" & @CRLF & _
"https://search.brave.com/search?q=regex+challenges&source=desktop" & @CRLF & _
"https://web.whatsapp.com/" & @CRLF & _
"https://www.youtube.com/watch?v=fc_RvxTtIwc" & @CRLF & _
"https://text-auditor.netlify.app/" & @CRLF & _
"https://github.com/Dashrath-Sharma" & @CRLF & _
"http://github.com/Dashrath-Sharma" & @CRLF & _
"https://onecompiler.com/javascript/3zqzyu2g4" & @CRLF & _
"http://localhost:3000/" & @CRLF & _
"https://www.codingame.com/clashofcode/clash/report/3342454a92e4c660d772438bac8b2ef73de3c8f" & @CRLF & _
"https://react.dev/learn/thinking-in-react" & @CRLF & _
"https://dapp-world.com/course/introduction-to-solidity-Ynws/working-of-traditional-dapps-compared-to-dapps/reading" & @CRLF & _
"" & @CRLF & _
"http://www.google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"http://www.google.com/" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"http://google.com/" & @CRLF & _
"https://google.com/" & @CRLF & _
"http://www.google.com/index.html" & @CRLF & _
"https://www.google.com/index.html" & @CRLF & _
"http://google.com/index.html" & @CRLF & _
"https://google.com/index.html" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")