$re = '/^[a-zA-Z0-9!#$%&’*+\/=?^_`{|}~.-]+@([a-zA-Z0-9\\\\-]+\.)*([a-zA-Z]){2,}$/';
$str = 'ab@ab';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);