$re = '/^(\s*\w+\s*=\s*new\s+\w+\s*\([^)]*\)\s*\;*\s*)$/';
$str = 'babeczka = new koteczek();';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);