const regex = /(^([A-Z]*)((:\/\/)?)([A-Z\d\.-]{2,})\.([A-Z]{2,}):(\d{2,5})?)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^([A-Z]*)((:\\\/\\\/)?)([A-Z\\d\\.-]{2,})\\.([A-Z]{2,}):(\\d{2,5})?)', 'i')
const str = `example.com:80/dir/subdir/file.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}