$re = '/^[-+]?[0-9]+([\,|\.][0-9]+)?$/m';
$str = '1.0
1,0
100000,10000
+10.0
10
1
-10.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);