#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^hotma.*(om|cm|co|et)$|^hotmail\.com[^\.].*$|^hotmail$|^h(to)?mail\.com"
Local $sString = "SQL Expression" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hotmail.es" & @CRLF & _
"hotmail.co.kr" & @CRLF & _
"hotmail.co.uk" & @CRLF & _
"hotmail.com.tw" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hotmail.com" & @CRLF & _
"hotmail" & @CRLF & _
"hotmailcom" & @CRLF & _
"htomail.com" & @CRLF & _
"hmail.com" & @CRLF & _
"hotmai.com" & @CRLF & _
"hotmail.cm" & @CRLF & _
"hotmail.net" & @CRLF & _
"hotmailc.om" & @CRLF & _
"hotmaol.com" & @CRLF & _
"homail.com" & @CRLF & _
"hotmail.co" & @CRLF & _
"hotmail.comahmedshakirny" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hotmail.com" & @CRLF & _
"hotmail" & @CRLF & _
"hotmailcom" & @CRLF & _
"htomail.com" & @CRLF & _
"hotmail.es" & @CRLF & _
"hotmail.co.kr" & @CRLF & _
"hotmail.co.uk" & @CRLF & _
"hmail.com" & @CRLF & _
"hotmai.com" & @CRLF & _
"hotmail.cm" & @CRLF & _
"hotmail.net" & @CRLF & _
"hotmailc.om" & @CRLF & _
"hotmaol.com" & @CRLF & _
"homail.com" & @CRLF & _
"hotmail.co" & @CRLF & _
"hotmail.comahmedshakirny" & @CRLF & _
"hotmail.comc" & @CRLF & _
"hotmail.comi" & @CRLF & _
"hotmail.om" & @CRLF & _
"hoymail.com" & @CRLF & _
"hitmail.com" & @CRLF & _
"hjotmail.com" & @CRLF & _
"hormail.com" & @CRLF & _
"hotgmail.com" & @CRLF & _
"hotmaii.com" & @CRLF & _
"hotmail..com" & @CRLF & _
"hotmail..comn" & @CRLF & _
"hotmail.com.lowercaseletter" & @CRLF & _
"hotmail.com.tw" & @CRLF & _
"hotmail.comgeorge4nyy" & @CRLF & _
"hotmail.comjehan.nizam09" & @CRLF & _
"hotmail.commn" & @CRLF & _
"hotmail.comn" & @CRLF & _
"hotmail.comorgmail.com" & @CRLF & _
"hotmail.comorvince1812" & @CRLF & _
"hotmail.con" & @CRLF & _
"hotmail.conm" & @CRLF & _
"hotmail.corp" & @CRLF & _
"hotmail.vom" & @CRLF & _
"hotmail.xom" & @CRLF & _
"hotmain.com" & @CRLF & _
"hotmaiul.com" & @CRLF & _
"hotmmail.com" & @CRLF & _
"hpotmail.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")