// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\(]([^\(]*\s*\))+[\)]").unwrap();
let string = "abc(c(asda asds))b(baasd(asd)c)c
The (as(quick nworb xof jumps) dog)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}