$re = '/"""(?:(?!""").)*(?:"{1,2}(?!"""))?"""/';
$str = 'r"gf\\" dgd""" fh" g\\" sgasd""" a" """ """""" \\adsadwqe"" asd"" """ "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);