$re = '/\d/';
$str = '1
2
3
4
5
6
7
8
9
10
11
0
a';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);