$re = '/^[0-1]{2,}1$/m';
$str = '10101
10
100
100000010
10101';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);