#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(^|(?<=\n))([0-2]\d{1}:[0-5]\d{1}:[0-5]\d{1}\.\d{3}) --> ([0-2]\d{1}:[0-5]\d{1}:[0-5]\d{1}\.\d{3})(.*?)((?=[0-2]\d{1}:[0-5]\d{1}:[0-5]\d{1}\.\d{3})|$)"
Local $sString = "00:00:34.355 --> 00:00:36.635" & @CRLF & _
"Бублики! Купите горячии бублики!" & @CRLF & _
"" & @CRLF & _
"00:00:37.315 --> 00:00:40.315" & @CRLF & _
"Ты что сделал, подлец?! Все ботинки мне изгадил!" & @CRLF & _
"" & @CRLF & _
"00:00:40.995 --> 00:00:42.155" & @CRLF & _
"Пошел вон!" & @CRLF & _
"" & @CRLF & _
"00:00:42.275 --> 00:00:46.875" & @CRLF & _
"Ваше благородие, да бросьте вы этого дурака!" & @CRLF & _
" Идите до сюда, зараз все исправим.Давайте." & @CRLF & _
"" & @CRLF & _
"00:00:48.275 --> 00:00:49.715" & @CRLF & _
"На, чисть быстро." & @CRLF & _
"" & @CRLF & _
"00:00:49.915 --> 00:00:57.715" & @CRLF & _
"Один момент. Такие сапоги перемазали, мама родная!" & @CRLF & _
" У меня вакса-то германская, фирма "Лавалин"." & @CRLF & _
"" & @CRLF & _
"00:00:57.915 --> 00:01:00.755" & @CRLF & _
"Не вакса, а масло просто, хоть на хлеб мажь." & @CRLF & _
"" & @CRLF & _
"00:01:01.795 --> 00:01:02.875" & @CRLF & _
"Чисть, чисть." & @CRLF & _
"" & @CRLF & _
"00:01:04.195 --> 00:01:05.315" & @CRLF & _
"Ой. Ваше благородие" & @CRLF & _
"" & @CRLF & _
"00:01:05.875 --> 00:01:06.955" & @CRLF & _
"Что с тобой?" & @CRLF & _
"" & @CRLF & _
"00:01:07.475 --> 00:01:08.875" & @CRLF & _
"Живот прихватило… Не могу.." & @CRLF & _
"" & @CRLF & _
"00:01:09.035 --> 00:01:10.355" & @CRLF & _
"Ты куда? Иди сюда" & @CRLF & _
"" & @CRLF & _
"00:01:10.635 --> 00:01:12.035" & @CRLF & _
" По нужде, ваше благородие!" & @CRLF & _
"" & @CRLF & _
"00:01:14.915 --> 00:01:18.355" & @CRLF & _
"А помнишь погром на Дальницкой? Дракон чертов" & @CRLF & _
"" & @CRLF & _
"00:01:30.595 --> 00:01:33.035" & @CRLF & _
"Или это я не знаю какая бывает жизнь?" & @CRLF & _
"" & @CRLF & _
"00:01:36.915 --> 00:01:39.955" & @CRLF & _
" Нас родила мама. Так же как и вас" & @CRLF & _
"" & @CRLF & _
"00:01:41.435 --> 00:01:46.195" & @CRLF & _
"Эта женщина - наша мама - хотела чтоб мы жили," & @CRLF & _
"" & @CRLF & _
"00:01:46.235 --> 00:01:48.035" & @CRLF & _
" а не мучались" & @CRLF & _
"" & @CRLF & _
"00:01:48.395 --> 00:01:50.955" & @CRLF & _
"Она хотела чтоб мы жили хорошо" & @CRLF & _
"" & @CRLF & _
"00:01:51.835 --> 00:01:55.515" & @CRLF & _
"и она была права," & @CRLF & _
"как может быть права только наша мама..." & @CRLF & _
"" & @CRLF & _
"00:01:57.275 --> 00:02:00.555" & @CRLF & _
"А Вы говорите, я не знаю, какая бывает жизнь..." & @CRLF & _
"" & @CRLF & _
"00:02:16.755 --> 00:02:18.395" & @CRLF & _
"Стой! Стоп!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")