$re = '/^(\d{6})(.csv$)/i';
$str = '123456.csv';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);