const regex = /(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail|detail\/photo\/(?:\w|\-)+)\/((?:\-|\w)+)(?:\w|&|=|\?)*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?(?:www\\.)?(?:gettyimages|gty)\\.(?:\\w+)\\\/(?:license|detail|detail\\\/photo\\\/(?:\\w|\\-)+)\\\/((?:\\-|\\w)+)(?:\\w|&|=|\\?)*', 'i')
const str = `http://www.gettyimages.com/license/182149877?share=site_twitter&plapla=asdasd&plfsdfapla=asdafdssd&plaasdpla=asdafsdsd fd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}