re = /(ReflectiveMethodInvocation.java:183)/
str = '(ReflectiveMethodInvocation.java:183)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end