$re = '/^[0-9]{4}$/m';
$str = '2222
33333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);