$re = '/<meta name="csrf-token" content="([^"]+)"/m';
$str = '<meta content="authenticity_token" name="csrf-param" />
<meta name="csrf-token" content="e9c9p1jcvcnt6MQ7v5Pkc98plga8g2dMGX6xC35vwFUS2OY=" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);