using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/?[S])|(\,)|([A-Z]\~[A-Z])|([A-Z]\-[A-Z]$)|([A-Z]\/[A-Z])|([A-Z]{2,}$)";
string input = @"60-B-1230S
60-B-1230ABCDEF
60-B-1230A-F
60-B-1230A/F
60-B-1230A~H,0290A~H
35-K-0101A/B,0201A/B,0301A/B
35-E-0102A~C, 0202A~C, 0302A~C
35-E-0103A~H, 0203A~H, 0303A~H
35-E-0101A/B, 0201A/B, 0301A/B
35-E-0104A/B, 0204A/B, 0304A/B
35-P-0101A/B, 0201A/B, 0301A/B
35-P-0102A/B, 0202A/B, 0302A/B
35-P-0103A/B, 0203A/B, 0303A/B
35-P-0104A/B, 0204A/B, 0304A/B
35-P-0105A/B, 0205A/B, 0305A/B
35-P-0106/S, 0206, 0306
35-P-0107/S, 0207, 0307
35-P-0109A/B, 0209A/B, 0309A/B
35-P-0111A/B
35-P-0401A/B
92-P-0101A/B
35-V-0108, 0208, 0308
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}