const regex = /\s?\+?\d{1,3}(\(|-|\s+)?\d+(\)|-|\s+)?(\d|-|\s)+\s?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?\\+?\\d{1,3}(\\(|-|\\s+)?\\d+(\\)|-|\\s+)?(\\d|-|\\s)+\\s?', '')
const str = `+767 918 000-12-34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}