package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{2}\. )\b([a-z])([a-z]+)\b`)
var str = `01. panoramica del corso`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}